Errores raros yum y rpm

Quiero instalar paquetes o actualizar y me da un error parecido a este:

-> Processing Dependency: ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) for package: lftp
–> Processing Dependency: libcrypto.so.6()(64bit) for package: lftp
–> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: lftp
—> Package nss-tools.x86_64 0:3.12.1.1-1.el5.centos.1 set to be updated
–> Processing Dependency: rtld(GNU_HASH) for package: nss-tools
–> Finished Dependency Resolution
Error: Missing Dependency: libc.so.6 is needed by package nss
Error: Missing Dependency: rtld(GNU_HASH) is needed by package syslinux
Error: Missing Dependency: rtld(GNU_HASH) is needed by package gdbm
Error: Missing Dependency: libc.so.6(GLIBC_2.0) is needed by package nss
Error: Missing Dependency: ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) is needed by package lftp
Error: Missing Dependency: libcrypto.so.6()(64bit) is needed by package lftp
Error: Missing Dependency: libc.so.6 is needed by package gdbm
Error: Missing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) is needed by package lftp
Error: Missing Dependency: libnspr4.so is needed by package nss
Error: Missing Dependency: libpcre.so.0()(64bit) is needed by package nmap
Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl-Digest-SHA1
Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl
Error: Missing Dependency: libc.so.6 is needed by package perl
Error: Missing Dependency: libcrypt.so.1 is needed by package perl
Error: Missing Dependency: libpthread.so.0(GLIBC_2.3.2) is needed by package perl
Error: Missing Dependency: libcrypto.so.6()(64bit) is needed by package nmap
Error: Missing Dependency: rtld(GNU_HASH) is needed by package mtr
Error: Missing Dependency: rtld(GNU_HASH) is needed by package nss
Error: Missing Dependency: libc.so.6(GLIBC_2.0) is needed by package perl
Error: Missing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) is needed by package nss
Error: Missing Dependency: rtld(GNU_HASH) is needed by package lftp
Error: Missing Dependency: rtld(GNU_HASH) is needed by package nss-tools
Error: Missing Dependency: libc.so.6(GLIBC_2.0) is needed by package gdbm
Error: Missing Dependency: rtld(GNU_HASH) is needed by package nmap

debes hacer un: rpm –rebuilddb

Si tienes dudas de consistencia de la BBDD de RPMs hazlo, en ningún caso tiene efecto negativo, en ocasiones ves errores de dependencias que no logras discernir que son, pues puede ser que la BBDD de rpm este corrompida y te da falsos errores.

This entry was posted in centos and tagged , , . Bookmark the permalink.

1 Response to Errores raros yum y rpm

  1. ./lib/rpm/__db.003
    ./lib/rpm/__db.002
    ./lib/rpm/__db.001
    ./lib/rpm/__db.000
    -bash-3.2# cd lib
    -bash-3.2# cd rpm
    -bash-3.2# rm __*

Leave a Reply

Your email address will not be published. Required fields are marked *